Adonit Jot Touch Original

Adonit's latest SDK does not support the earlier version of Jot Touch anymore. This has been confirmed with the Adonit guys. Kindly contact them for further details regarding this.

Have more questions? Submit a request

0 Comments

Article is closed for comments.